Outbound Dialing Issue

Incident Report for Convoso

Resolved

The issue was identified and fully restored for all affected customers by 11.06 am PDT. An RFO will be issued in due course. We thank you for your patience as we investigated and rectified the issue.
Posted Jul 27, 2026 - 11:06 PDT

Investigating

We are currently investigating reports of outbound dialing degradation from a subset of our customers. We are treating this as a priority issue.
Posted Jul 27, 2026 - 08:54 PDT
This incident affected: Agent Interface (Dialer) and Admin Interface (Campaigns and Hopper).